CVE-2026-12887: Path Traversal in Octopus Server
Affects Octopus ServerSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium · fixed in 2026.3.5839 : update Octopus Server when convenient.
Data as of 27 Oct 2026, 13:57 UTC
- Patch
- Available – fixed in 2026.3.5839, 2026.2.973, 2026.1.674
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Octopus Server to 2026.3.5839, 2026.2.973 or 2026.1.674.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Octopus DeployOctopus Server | Affected
| Fixed in
|
AI-suggested
Upgrade Octopus Server to one of the fixed versions: 2026.1.674, 2026.2.973, or 2026.3.5839. Applying these official fixes will remediate the path traversal vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-12887 is a path traversal vulnerability in Octopus Server that allows a user with permission to upload a malicious NuGet package to deploy a script step executing outside the intended directory. This could lead to unauthorized script execution beyond the parent directory boundaries. The vulnerability affects multiple versions of Octopus Server prior to fixed releases in 2026.1.674, 2026.2.973, and 2026.3.5839. The CVSS 4.0 score is 5.1, indicating a medium severity risk.