CVE-2026-12958: Language Servers for AWS · UNIX symbolic link (symlink) following
Affects Language Servers for AWSSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 1.69.0 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.69.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Language Servers for AWS to 1.69.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Amazon Web ServicesLanguage Servers for AWS | Affected
| Fixed in
|
AI-suggested
Upgrade the AWS Language Servers to version 1.69.0 or later, as this version contains the fix for the symlink validation vulnerability. Since this is a cloud service managed by AWS, the vendor handles remediation server-side. Users should verify they are using the updated version per the AWS security bulletin at https://aws.amazon.com/security/security-bulletins/2026-047-aws/.
Description
Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.