Skip to main content
VulnerabilityPublished

CVE-2026-12982: Document Gallery (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Document Gallery (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.1.1 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Document Gallery (WordPress plugin) to 5.1.1.

Affected software

ProductAffectedFixed in
Document GalleryAffected
  • <5.1.1
Fixed in
  • 5.1.1

AI-suggested

If you cannot patch yet, consider disabling or restricting access to the vulnerable AJAX action if possible.

Description

The Document Gallery WordPress plugin before 5.1.1 does not properly sanitise and escape user input before reflecting it back in the response of an unauthenticated AJAX action, leading to a Reflected Cross-Site Scripting vulnerability which can be exploited against unauthenticated users.

References

Community reviews

Loading reviews…