CVE-2026-1321: Membership Plugin – Restrict Content · Missing Authorization
Affects Membership Plugin – Restrict ContentSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 3.2.18 : patch Membership Plugin – Restrict Content soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.18
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| stellarwpMembership Plugin – Restrict Content | Affected
| Fixed in– |
AI-suggested
Users should check the vendor advisory for current remediation guidance. Since a partial patch was introduced in version 3.2.18 but versions up to 3.2.20 remain vulnerable, upgrading to a version beyond 3.2.20 if available or applying vendor-recommended fixes is advised. Until an official fix is confirmed, restricting access to the registration endpoint or disabling the plugin may reduce risk.
Description
The Membership Plugin – Restrict Content plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.2.20. This is due to the `rcp_setup_registration_init()` function accepting any membership level ID via the `rcp_level` POST parameter without validating that the level is active or that payment is required. Combined with the `add_user_role()` method which assigns the WordPress role configured on the membership level without status checks, this makes it possible for unauthenticated attackers to register with any membership level, including inactive levels that grant privileged WordPress roles such as Administrator, or paid levels that charge a sign-up fee. The vulnerability was partially patched in version 3.2.18.
References
- wordfence.com/threat-intel/vulnerabilities/id/abfaa4a6-92b0-4233-b08d-e668090d3fc2?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/registration-functions.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/registration-functions.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/class-rcp-registration.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/restrict-content/tags/3.2.15/core/includes/memberships/class-rcp-membership.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3447187/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3460177/ (opens in a new tab)