CVE-2026-14223: Easy Appointments (WordPress plugin) · Insecure Direct Object Reference
Affects Easy Appointments (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 3.12.28 when convenient.
Data as of 29 Oct 2026, 07:15 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.12.28
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Easy Appointments (WordPress plugin) to 3.12.28.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Easy Appointments | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict subscriber-level access to trusted users only and monitor for suspicious activity related to customer data access.
Description
The Easy Appointments WordPress plugin before 3.12.28 does not verify ownership or capability when returning stored customer details, allowing users with subscriber-level access to read any customer's personal information by iterating an identifier.