Skip to main content
VulnerabilityPublished

CVE-2026-14317: GiveWP (WordPress plugin) · Missing Authorization

Affects GiveWP (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.16.3 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.16.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade GiveWP (WordPress plugin) to 4.16.3.

Affected software

ProductAffectedFixed in
GiveWPAffected
  • <4.16.3
Fixed in
  • 4.16.3

AI-suggested

Until then, consider restricting access to the donation functionality or implementing additional access controls if feasible.

Description

GiveWP WordPress plugin versions before 4.16.3 contain a missing authorization vulnerability that allows unauthenticated users to use payment gateways disabled by the administrator to complete donations. This occurs because the plugin does not properly restrict payment gateway selection, partially relying on request input. The vulnerability has a medium severity rating with a CVSS score of 5.3.

References

Community reviews

Loading reviews…