CVE-2026-14834: Mailgun for WordPress · Improper Access Control
Affects Mailgun for WordPressSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.2.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Mailgun for WordPress to 2.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mailgun for WordPress | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, site owners should consider disabling the vulnerable AJAX action or restricting access to it via other means. Monitoring for unusual subscription activity may help detect exploitation attempts.
Description
Mailgun for WordPress versions prior to 2.2.1 contain an improper access control vulnerability. The plugin fails to perform capability or nonce checks on an unauthenticated AJAX action that adds subscribers to mailing lists. This allows unauthenticated attackers to add arbitrary email addresses to the site owner's configured mailing lists using the owner's stored API credentials.