Skip to main content
VulnerabilityPublished Updated

CVE-2026-14841: King Addons for Elementor (WordPress plugin) · Cross-Site Scripting (XSS)

Affects King Addons for Elementor (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 51.1.76 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 51.1.76
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade King Addons for Elementor (WordPress plugin) to 51.1.76.

Affected software

ProductAffectedFixed in
King Addons for ElementorAffected
  • <51.1.76
Fixed in
  • 51.1.76

AI-suggested

If you cannot patch yet, users should exercise caution when interacting with untrusted content that may trigger the vulnerable AJAX response. Monitoring for updates from the plugin vendor is recommended to apply any forthcoming patches promptly.

Description

CVE-2026-14841 is a cross-site scripting (XSS) vulnerability in the King Addons for Elementor WordPress plugin before version 51.1.76. The plugin fails to properly escape a user-supplied grid setting before reflecting it into an HTML attribute in an unauthenticated AJAX response. This flaw allows attackers to execute arbitrary JavaScript in the browsers of visitors who load a crafted page. The vulnerability has a CVSS score of 6.1, indicating a medium severity level.

References

Community reviews

Loading reviews…