CVE-2026-14845: NewStatPress (WordPress plugin) · Cross-Site Scripting (XSS)
Affects NewStatPress (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.4.5 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade NewStatPress (WordPress plugin) to 1.4.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NewStatPress | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider disabling the affected widget or restricting access to it to trusted users only. Monitoring for updates from the plugin vendor or WordPress security advisories is recommended.
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in the NewStatPress WordPress plugin versions before 1.4.5. The plugin fails to sanitize and escape data from unauthenticated visitor requests before storing and later displaying it in a widget. This flaw could allow unauthenticated attackers to inject malicious scripts that execute in the browsers of users viewing the affected widget.