CVE-2026-14864: JetEngine (WordPress plugin) · Cross-Site Scripting (XSS)
Affects JetEngine (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 3.8.12 when convenient.
Data as of 1 Nov 2026, 08:20 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.8.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade JetEngine (WordPress plugin) to 3.8.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetEngine | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict Contributor and higher roles from untrusted users and consider disabling or limiting the use of affected shortcodes that output post meta values.
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in the JetEngine WordPress plugin versions prior to 3.8.12. This flaw allows users with Contributor role or higher to inject malicious scripts via post meta values that are not properly escaped when output through certain shortcodes. The injected scripts execute in the context of higher-privileged users, such as administrators.