CVE-2026-14922: WP Photo Album Plus · Cross-Site Scripting (XSS)
Affects WP Photo Album PlusSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 9.2.04.003 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.2.04.003
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade WP Photo Album Plus to 9.2.04.003.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WP Photo Album Plus | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should consider disabling or restricting the comment functionality or applying additional input validation/sanitization controls if possible.
Description
WP Photo Album Plus versions up to and including 9.2.03.001 are vulnerable to a stored Cross-Site Scripting (XSS) flaw. The vulnerability arises from a double-encoding issue in the photo-comment pipeline, where a double HTML-entity-encoded payload bypasses sanitization and is stored in a decoded form. This allows an attacker to inject malicious scripts that could execute in the context of other users viewing the comments.