Skip to main content
VulnerabilityPublished

CVE-2026-15240: Customer Switching (WordPress plugin) · Improper Authentication

Affects Customer Switching (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.1.3 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Customer Switching (WordPress plugin) to 2.1.3.

Affected software

ProductAffectedFixed in
Customer SwitchingAffected
  • <2.1.3
Fixed in
  • 2.1.3

AI-suggested

Until then, restrict use of the plugin to trusted users and consider disabling it if possible.

Description

The Customer Switching WordPress plugin before version 2.1.3 contains an improper authentication vulnerability that allows a lower-privileged user, currently switched into by an operator, to be resolved as that operator and switch into any permitted account, including administrator accounts. This flaw can lead to full account takeover.

References

Community reviews

Loading reviews…