CVE-2026-15256: Ninja Forms (WordPress plugin) · Injection
Affects Ninja Forms (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 3.14.10 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.14.10
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Ninja Forms (WordPress plugin) to 3.14.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Ninja Forms | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, avoid embedding vulnerable Ninja Forms that pre-populate fields from user-supplied query strings or restrict access to such forms.
Description
Ninja Forms WordPress plugin versions before 3.14.10 allow unauthenticated attackers to execute arbitrary shortcodes via user-supplied query-string input used to pre-populate form fields. This occurs because the plugin does not prevent such input from being processed as shortcodes when embedded on public pages.