CVE-2026-15257: RegistrationMagic (WordPress plugin) · Insecure Direct Object Reference
Affects RegistrationMagic (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 6.0.9.4 when convenient.
Data as of 29 Oct 2026, 07:15 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.9.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade RegistrationMagic (WordPress plugin) to 6.0.9.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RegistrationMagic | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the affected functionality and monitor for suspicious activity related to form submission edits.
Description
RegistrationMagic WordPress plugin versions before 6.0.9.4 contain an authorization bypass vulnerability. This flaw allows unauthenticated attackers to overwrite form submissions and profile fields of non-administrator WordPress accounts due to missing authorization, ownership, or nonce checks on front-end submission editing.