Skip to main content
CVE-2026-1540VulnerabilityPublished

CVE-2026-1540: Spam Protect for Contact Form 7 (WordPress plugin) · Code Injection

Affects Spam Protect for Contact Form 7 (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.2 High : upgrade to 1.2.10 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Spam Protect for Contact Form 7 (WordPress plugin) to 1.2.10.

Affected software

ProductAffectedFixed in
Spam Protect for Contact Form 7Affected
  • <1.2.10
Fixed in
  • 1.2.10

AI-suggested

If you cannot patch yet, restrict editor-level access to trusted users only and monitor for suspicious activity related to the plugin. Consider disabling or removing the plugin if possible to reduce risk.

Description

CVE-2026-1540 is a high-severity vulnerability in the Spam Protect for Contact Form 7 WordPress plugin versions before 1.2.10. It allows an attacker with editor-level access to achieve remote code execution by exploiting improper control over code generation through logging to a PHP file using a crafted header. The vulnerability is classified as CWE-94, indicating code injection issues. The CVSS score is 7.2, reflecting high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…