Skip to main content
VulnerabilityPublished

CVE-2026-1555: WebStack (WordPress theme) · Unrestricted File Upload

Affects WebStack (WordPress theme)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.2024 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2024
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade owen0o0/WebStack to 1.2024.

Affected software

ProductAffectedFixed in
OwenWebStackAffected
  • <=1.2024
Fixed in–
GitHubowen0o0/WebStackpkg:github/owen0o0/WebStackOther threatsAffected
  • <1.2024
Fixed in
  • 1.2024

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, it is recommended to disable or restrict the vulnerable file upload functionality if possible, and monitor for suspicious file uploads. Avoid exposing the vulnerable theme on public-facing sites or restrict access to trusted users only.

Description

The Owen WebStack WordPress theme contains a critical vulnerability (CVE-2026-1555) due to missing file type validation in the io_img_upload() function. This flaw allows unauthenticated attackers to upload arbitrary files to the affected server, potentially enabling remote code execution. The vulnerability affects all versions up to and including 1.2024. The CVSS score is 9.8, indicating a critical severity level.

References

Community reviews

Loading reviews…