Skip to main content
VulnerabilityPublished

CVE-2026-1564: Pegasystems Pega Infinity · Basic XSS

Affects Pegasystems Pega InfinitySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to Infinity 25.1.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in Infinity 25.1.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Pegasystems Pega Infinity to Infinity 25.1.2.

Affected software

ProductAffectedFixed in
PegasystemsPega InfinityAffected
  • =8.1.0
Fixed in
  • Infinity 25.1.2
Mavencom.pega/pega-infinitypkg:maven/com.pega/pega-infinityOther threatsAffected
  • =8.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict developer role access to trusted personnel only and monitor for suspicious activity involving user interface components. No vendor-provided mitigation or temporary fix is currently documented.

Description

CVE-2026-1564 is an HTML Injection vulnerability affecting Pegasystems Pega Infinity versions 8.1.0 through 25.1.1. It involves improper neutralization of script-related HTML tags in a user interface component. Exploitation requires a high privileged user with a developer role. The vulnerability has a medium severity with a CVSS score of 5.1.

References

Community reviews

Loading reviews…