Skip to main content
CVE-2026-15738VulnerabilityPublished

CVE-2026-15738: aws-load-balancer-controller · Improper isolation or compartmentalization

Affects aws-load-balancer-controllerSource GCVE Database

0

Not known to be exploited · CVSS 5.8 Medium · patch available : update aws-load-balancer-controller when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 4.0 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
Amazon aws-load-balancer-controllerAffected
  • =0
Fixed in–

AI-suggested

Users should upgrade the AWS Load Balancer Controller to version 3.4.2 or later to remediate this vulnerability. Since this is a cloud-managed controller, the vendor manages remediation for the cloud-hosted service, but customers running the controller themselves must apply the update.

Description

CVE-2026-15738 is a vulnerability in Amazon AWS Load Balancer Controller versions before 3.4.2 where improper isolation in Gateway API listener-rule generation allows an authenticated remote user to intercept, spoof, or deny gRPC traffic of another namespace on a shared Gateway by crafting a malicious HTTPRoute resource. The issue is resolved by upgrading to version 3.4.2.

Reports on CVE-2026-15738

References

Community reviews

Loading reviews…