CVE-2026-15892: zephyrproject zephyr · Dos
Affects zephyrproject zephyrSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.4.2 when convenient.
Data as of 29 Oct 2026, 07:15 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 13 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade zephyrproject zephyr to 4.4.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| zephyrprojectzephyr | Affected
| Fixed in
|
GitHubzephyrpkg:github/zephyrOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid configurations that enable both CONFIG_MCUMGR_GRP_SETTINGS_BUFFER_TYPE_HEAP and CONFIG_MCUMGR_GRP_SETTINGS_ACCESS_HOOK with hooks that reject requests using MGMT_CB_ERROR_RC. Alternatively, use the default stack buffer type which is not vulnerable to this leak.
Description
CVE-2026-15892 is a denial of service vulnerability in the Zephyr project's mcumgr SMP settings-management handlers. When configured to use heap buffers and an access hook that rejects requests, the handlers leak heap memory on each rejected request. This leak eventually exhausts the kernel heap, causing k_malloc() failures and service denial. The vulnerability affects versions from 3.5.0 up to but not including 4.4.2. The impact is limited to availability with no memory corruption or information disclosure.