CVE-2026-15931: Simple Membership (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Simple Membership (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.7.8 when convenient.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.7.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade Simple Membership (WordPress plugin) to 4.7.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Simple Membership | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, administrators should exercise caution when reviewing payment approval requests and consider restricting access to the dashboard or implementing additional input validation and output escaping controls as temporary mitigations.
Description
A Cross-Site Scripting (XSS) vulnerability exists in the Simple Membership WordPress plugin before version 4.7.8. The plugin fails to sanitize a subscriber name value received from an unauthenticated payment approval request and does not escape it when displaying in the admin dashboard. This allows unauthenticated attackers to inject and store arbitrary JavaScript that executes in an administrator's session, potentially leading to session hijacking or other malicious actions.