Skip to main content
VulnerabilityPublished Updated

CVE-2026-15970: HashiCorp Consul · Non-Canonical URL Authorization

Affects HashiCorp ConsulSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.2 Medium : upgrade to 2.0.3 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.3, 1.21.17
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Consul and Consul Enterprise to 2.0.3; Consul Enterprise to 1.21.17.

Affected software

ProductAffectedFixed in
HashiCorpConsulAffected
  • >=1.20.1 <2.0.3
Fixed in
  • 2.0.3
HashiCorpConsul EnterpriseAffected
  • >=1.20.1 <1.21.17
Fixed in
  • 2.0.3
GitHubConsulpkg:github/ConsulOther threatsAffected
  • >=1.20.1 <2.0.3
Fixed in
  • 2.0.3
GitHubConsul Enterprisepkg:github/Consul EnterpriseOther threatsAffected
  • >=1.20.1 <1.21.17
Fixed in
  • 1.21.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Consul versions to 2.0.3 or later for Community Edition, or to 1.21.17, 1.22.11, or 2.0.3 for Consul Enterprise. Patch availability is confirmed by the vendor advisory. No alternative mitigations are specified.

Description

Consul Community Edition and Consul Enterprise 1.20.1 through 2.0.2 are vulnerable to an L7 intention authorization bypass when a service proxy is configured with a custom public listener. An authenticated mesh workload may reach HTTP paths that are blocked by a path-based deny intention. This vulnerability, CVE-2026-15970, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

References

Community reviews

Loading reviews…