CVE-2026-16065: Welcart e-Commerce (WordPress plugin) · SQL Injection
Affects Welcart e-Commerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.11.32 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.11.32
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Welcart e-Commerce (WordPress plugin) to 2.11.32.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Welcart e-Commerce | Affected
| Fixed in
|
AI-suggested
Since the vulnerability affects versions before 2.11.32, upgrading to version 2.11.32 or later is recommended once the vendor confirms the fix. Until then, restrict Editor and higher roles from importing CSV files or performing actions that involve this functionality if possible.
Description
A SQL injection vulnerability exists in the Welcart e-Commerce WordPress plugin before version 2.11.32. The flaw arises because the plugin does not properly sanitize values imported from CSV files before using them in SQL statements. This vulnerability allows users with Editor role or higher, including custom shop-management roles, to perform SQL injection attacks.