CVE-2026-16289: ProfileGrid (WordPress plugin) · Missing Authorization
Affects ProfileGrid (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.0.0.0 when convenient.
Data as of 2 Nov 2026, 10:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade ProfileGrid (WordPress plugin) to 6.0.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ProfileGrid | Affected
| Fixed in
|
AI-suggested
Users should upgrade to ProfileGrid version 6.0.0.0 or later once available, as the vulnerability affects all versions prior to 6.0.0.0. If you cannot patch yet, restrict authenticated user roles or limit group membership request visibility as a temporary measure.
Description
ProfileGrid WordPress plugin versions before 6.0.0.0 contain a missing authorization vulnerability that allows any authenticated user, including Subscribers, to view pending membership requests for any group, even private ones. This exposure reveals the names and request dates of users awaiting group approval. The vulnerability does not allow modification or denial of service but discloses sensitive membership information.