CVE-2026-16547: REST API Log (WordPress plugin) · Improper Access Control
Affects REST API Log (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 1.7.1 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade REST API Log (WordPress plugin) to 1.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| REST API Log | Affected
| Fixed in
|
AI-suggested
Since the vulnerability affects versions before 1.7.1, upgrading to version 1.7.1 or later is recommended once confirmed by the vendor. If you cannot patch yet, restrict access to the log download feature and monitor for unauthorized token usage.
Description
The REST API Log WordPress plugin before version 1.7.1 has an improper access control vulnerability in its log download feature. The plugin does not bind the token protecting log downloads to the specific log entry nor verify the requester's capabilities. This allows unauthenticated users who possess any valid token to download REST API request and response logs, potentially exposing sensitive data such as credentials and authentication tokens.