CVE-2026-16623: Create Block Theme · Code Injection
Affects Create Block ThemeSource CVE Database V5
Not known to be exploited · CVSS 8.0 High : upgrade to 2.10.0 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade Create Block Theme to 2.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Create Block Theme | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict multisite subsite administrator capabilities where possible and monitor for suspicious activity related to PHP file generation. Avoid granting multisite subsite administrator roles to untrusted users.
Description
CVE-2026-16623 is a high-severity code injection vulnerability in the Create Block WordPress plugin before version 2.10.0. It allows a multisite subsite administrator, who has certain capabilities but is normally restricted from editing PHP files, to inject and execute arbitrary PHP code on the server. This occurs because user-supplied text is not properly escaped before being written into a generated PHP pattern file.