CVE-2026-1711: Pegasystems Pega Infinity · Cross-site Scripting
Affects Pegasystems Pega InfinitySource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to Infinity 25.1.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in Infinity 25.1.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Pegasystems Pega Infinity to Infinity 25.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PegasystemsPega Infinity | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict developer role assignments to trusted personnel only and monitor for suspicious activity related to user interface components. Avoid granting unnecessary high privileges to users.
Description
Pega Infinity versions 8.1.0 through 25.1.1 contain a stored Cross-Site Scripting (XSS) vulnerability in a user interface component. Exploitation requires a high privileged user with a developer role to inject malicious scripts. The vulnerability is classified as CWE-79 and has a CVSS 4.8 (medium) severity rating. There are no known exploits in the wild at this time.