Skip to main content
CVE-2026-17192VulnerabilityPublished

CVE-2026-17192: Arista Networks VeloCloud Orchestrator On-Prem · Server-Side Request Forgery (SSRF)

Affects Arista Networks VeloCloud Orchestrator On-PremSource CVE Database V5

0

Not known to be exploited · CVSS 8.5 High · fixed in 6.4.2.4 : patch Arista Networks VeloCloud Orchestrator On-Prem soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.4.2.4, 6.1.3.4, 5.2.3.14
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Arista Networks VeloCloud Orchestrator On-Prem to 6.4.2.4, 6.1.3.4 or 5.2.3.14.

Affected software

ProductAffectedFixed in
Arista NetworksVeloCloud Orchestrator On-PremAffected
  • >=5.2.0 <5.2.3.14
  • >=6.1.0 <6.1.3.4
  • >=6.4.0 <6.4.2.4
Fixed in
  • 6.4.2.4
  • 6.1.3.4
  • 5.2.3.14

AI-suggested

If you cannot patch yet, restrict Enterprise Standard Admin role assignments to trusted personnel only and review access controls to minimize risk.

Description

A VCO feature does not sufficiently validate caller-supplied input, allowing requests to be made on behalf of authenticated tenant accounts to internal services that are not otherwise accessible. This vulnerability requires a minimum role of Enterprise Standard Admin. This issue was discovered internally by Arista and the company is not aware of any malicious uses of this issue in customer networks.

References

Community reviews

Loading reviews…