Skip to main content
VulnerabilityPublished

CVE-2026-17348: pgAdmin 4 · Missing Authentication

Affects pgAdmin 4Source CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 9.17 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.17.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • >=1.0 <9.17
Fixed in
  • 9.17
pgadmin.orgpgAdmin 4Affected
  • >=4.18 <9.17
Fixed in
  • 9.17
pgadmin.orgpgAdmin 4Affected
  • >=8.2 <9.17
Fixed in
  • 9.17
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • >=1.0 <9.17
  • >=4.18 <9.17
  • >=8.2 <9.17
Fixed in
  • 9.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The fix involves adding the missing @pga_login_required decorator to the affected routes. Until an official patch or update is available, restrict network access to pgAdmin 4 SERVER mode instances and monitor for unusual activity related to these routes.

Description

In SERVER mode, pgAdmin 4 enforces authentication per route via the @pga_login_required decorator; the application's before_request hook only handles desktop-mode auto-login and the Kerberos/Webserver-auth redirect, so any route shipped without the decorator is reachable without authentication (CWE-306). This is the same defect class previously fixed as CVE-2026-12046 (the sqleditor close/update_connection routes). A follow-up sweep, prompted by a report describing an incomplete fix for CVE-2026-12046, found further routes missing @pga_login_required: the Constraints blueprint's nodes and proplist (object listing) routes and its delete route (a state-mutating DELETE that removes table constraints); preferences.get_all_cli (GET, discloses all CLI-settable preference values); debugger.close (DELETE); and schema_diff.close (DELETE). An unauthenticated network client could therefore enumerate constraint metadata, delete table constraints, read preference values, and force-close debugger or schema-diff sessions belonging to other users, without ever authenticating. Fix adds the missing @pga_login_required decorator (and the corresponding import to the Constraints module) to each of these routes. The change is decorator-only; no behavioral changes to the underlying handlers. This issue affects pgAdmin 4 in SERVER mode: the Constraints and Debugger routes from 1.0, the Schema Diff close route from 4.18, and preferences.get_all_cli from 8.2, all before 9.17.

References

Community reviews

Loading reviews…