Skip to main content
VulnerabilityPublished

CVE-2026-17543: PHP · SQL Injection

Affects PHPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High · fixed in 8.5.9 : patch PHP soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.9, 8.4.24, 8.3.33 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:Y/R:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PHP and the Debian debian/php package to 8.5.9, 8.4.24, 8.3.33 or 8.2.33.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.9
Fixed in
  • 8.5.9
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.24
Fixed in
  • 8.4.24
PHP GroupPHPAffected
  • ≥ 8.3.*, < 8.3.33
Fixed in
  • 8.3.33
PHP GroupPHPAffected
  • ≥ 8.2.*, < 8.2.33
Fixed in
  • 8.2.33
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.2.33
  • <8.3.33
  • <8.4.24
  • <8.5.9
Fixed in
  • 8.2.33
  • 8.3.33
  • 8.4.24
  • 8.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should monitor vendor communications closely and consider applying any recommended temporary mitigations once published.

Description

CVE-2026-17543 is a high-severity SQL injection vulnerability in PHP caused by improper escaping of backslashes in attacker-supplied parameters. It affects multiple PHP versions prior to 8.2.33, 8.3.33, 8.4.24, and 8.5.9. This flaw allows attackers to perform SQL injection attacks due to improper neutralization of special elements in SQL commands.

References

Community reviews

Loading reviews…