CVE-2026-17570: Devolutions Server · Insecure Direct Object Reference
Affects Devolutions ServerSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 2026.2.14 or 2026.1.24 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.2.14, 2026.1.24
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Devolutions Server to 2026.2.14 or 2026.1.24.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DevolutionsServer | Affected
| Fixed in
|
| DevolutionsServer | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the PAM password history endpoints to trusted users only and monitor for unusual API request patterns. Avoid granting unnecessary privileges to users who do not require access to sensitive credential data.
Description
Improper access control in the PAM password history endpoints in Devolutions Server allows an authenticated low-privileged user to disclose plaintext credential secrets via crafted API requests. This issue affects : * Devolutions Server 2026.2.4.0 through 2026.2.12.0 * Devolutions Server 2026.1.23.0 and earlier