Skip to main content
VulnerabilityPublished

CVE-2026-18157: RedHatInsights yggdrasil-worker-package-manager · Argument Injection

Affects RedHatInsights yggdrasil-worker-package-managerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 0.2.4 or 0.1.4 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.2.4, 0.1.4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade RedHatInsights yggdrasil-worker-package-manager to 0.2.4 or 0.1.4.

Affected software

ProductAffectedFixed in
RedHatInsightsyggdrasil-worker-package-managerAffected
  • >=0.2.0 <0.2.4
Fixed in
  • 0.2.4
RedHatInsightsyggdrasil-worker-package-managerAffected
  • <0.1.4
Fixed in
  • 0.1.4
GitHubyggdrasil-worker-package-managerpkg:github/yggdrasil-worker-package-managerOther threatsAffected
  • <0.1.4
  • >=0.2.0 <0.2.4
Fixed in
  • 0.1.4
  • 0.2.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict local access to trusted users only and monitor for suspicious activity related to package management commands.

Description

CVE-2026-18157 is an argument injection vulnerability in the yggdrasil-worker-package-manager's APT backend. A local attacker with system access can exploit specially crafted package names starting with a hyphen, causing apt-get to misinterpret them as command options. This flaw can lead to remote code execution with root privileges, fully compromising system integrity, confidentiality, and availability. The vulnerability affects specific versions of yggdrasil-worker-package-manager.

References

Community reviews

Loading reviews…