CVE-2026-18481: Stored XSS in Participant URL Field leads to Account Takeover via Session Token Theft
Source AWS Security Bulletins
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.8 High : upgrade to 3.8.0 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.8.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Amazon OpenSearch Service and OpenSearch Dashboards to 3.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSAmazon OpenSearch Service | Affected
| Fixed in
|
| OpenSearchOpenSearch Dashboards | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, consider limiting access to the affected plugin and monitoring for suspicious activity related to prototype pollution vectors.
Description
Bulletin ID: 2026-085-AWS Scope: AWS Content Type: Important (requires attention) Publication Date: 08/20/2026 13:30 PM PDT Description: Improper input validation in the Time Series Visual Builder (TSVB) plugin in OpenSearch Dashboards before 3.8 allows a remote authenticated user with standard data access permissions to execute arbitrary code on the server by sending a crafted JSON payload to the metrics visualization API endpoint. To mitigate this issue, users should upgrade to OpenSearch Dashboards 3.8 or later. Impacted products and versions: - OpenSearch-Dashboards (open-source, self-managed): >=3.0.0, =3.0.0, <3.8.0 Please refer to the article below for the most up-to-date and complete information related to this AWS Security Bulletin.