CVE-2026-18458: RTI Connext Professional · Out-of-bounds Read
Affects RTI Connext ProfessionalSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 7.7.0.1 or 7.3.1.6 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.7.0.1, 7.3.1.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade RTI Connext Professional to 7.7.0.1 or 7.3.1.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RTIConnext Professional | Affected
| Fixed in
|
AI-suggested
Until then, restrict local access to trusted users and environments to minimize risk.
Description
CVE-2026-18458 is a medium severity vulnerability in RTI Connext Professional Core Libraries involving out-of-bounds read, incorrect function call arguments, and type confusion. It affects versions 6.1.2.21, 7.3.0 up to but not including 7.3.1.6, and 7.4.0 up to but not including 7.7.0.1. The flaw allows overreading buffers, potentially leading to unauthorized data access or application instability.