Skip to main content
VulnerabilityPublished Updated

CVE-2026-19012: HashiCorp Consul · NULL Pointer Dereference

Affects HashiCorp ConsulSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.0.3 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.3, 1.21.17
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Consul and Consul Enterprise to 2.0.3; Consul Enterprise to 1.21.17.

Affected software

ProductAffectedFixed in
HashiCorpConsulAffected
  • >=1.18.0 <2.0.3
Fixed in
  • 2.0.3
HashiCorpConsul EnterpriseAffected
  • >=1.18.0 <1.21.17
Fixed in
  • 2.0.3
GitHubConsulpkg:github/ConsulOther threatsAffected
  • >=1.18.0 <2.0.3
Fixed in
  • 2.0.3
GitHubConsul Enterprisepkg:github/Consul EnterpriseOther threatsAffected
  • >=1.18.0 <1.21.17
Fixed in
  • 1.21.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Consul Community Edition versions to 2.0.3 or later. For Enterprise Edition, upgrade to versions 1.21.17, 1.22.11, or 2.0.3 or later. No other mitigation or workaround is indicated. Patch status is confirmed fixed in these versions.

Description

Consul Community Edition and Consul Enterprise 1.18.0 through 2.0.2 are vulnerable to an authenticated denial of service in the Enterprise-to-Community Edition downgrade path that may allow an authorized caller to crash the Consul server. A caller with config-entry write permission can submit a service-router configuration entry that causes the agent to exit unexpectedly. This vulnerability, CVE-2026-19012, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.

References

Community reviews

Loading reviews…