CVE-2026-19022: OpenHands · Command Injection
Affects OpenHandsSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium · fixed in 1.7.0 : update OpenHands when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 1.8% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenHands | Affected
| Fixed in– |
GitHubopenhands/OpenHandspkg:github/openhands/OpenHandsOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:openhands:openhands:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vulnerable code path was removed in OpenHands version 1.7.0. Users should upgrade to version 1.7.0 or later to mitigate this vulnerability. Until upgrading, restrict network access to affected versions to reduce exposure.
Description
CVE-2026-19022 is a command injection vulnerability in OpenHands versions up to 0.62.0. It affects the function initialize_repo in the file OpenHands/resolver/send_pull_request.py. The vulnerable code path was removed in version 1.7.0. Remote exploitation is possible, allowing an attacker to execute arbitrary commands. The vulnerability has a medium severity with a CVSS score of 5.3.