CVE-2026-19359: nxp-auto-goldvip gvip · Improper Access Controls
Affects nxp-auto-goldvip gvipSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium · patch available : update nxp-auto-goldvip gvip when convenient.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 9 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nxp-auto-goldvipgvip | Affected
| Fixed in– |
GitHubnxp-auto-goldvip/gvippkg:github/nxp-auto-goldvip/gvipOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:nxp-auto-goldvip:gvip:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading to nxp-auto-goldvip gvip version 1.15.0 or later. The vendor has addressed the IAM permission misconfiguration starting with version 1.13.0 and improved it in subsequent releases. Since this is a cloud service, the vendor manages remediation server-side. Users should verify they are running a version >=1.15.0 and consult the vendor advisory for any additional guidance. Older versions should be updated or deprecated as per vendor recommendations.
Description
CVE-2026-19359 is a medium severity vulnerability in the nxp-auto-goldvip gvip product up to version 1.4.0. It involves improper access controls in the SitewiseCustomFunction of the Lambda Function Handler component, allowing remote attackers to exploit the issue. The vulnerability stems from a known historical IAM permission misconfiguration that was addressed starting with version 1.13.0 and improved in subsequent releases including 1.15.0. Users are advised to upgrade to version 1.15.0 or later to resolve the issue. The vendor has also requested updating or deprecating older releases in the AWS SAR repository. The product is a cloud service, so remediation is managed by the vendor.