CVE-2026-19599: Zohocorp ManageEngine OpManager · OS Command Injection
Affects Zohocorp ManageEngine OpManagerSource CVE Database V5
Not known to be exploited · CVSS 9.9 Critical : upgrade to 12.8.711 as a priority.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 5.0% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 12.8.711
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Zohocorp ManageEngine OpManager to 12.8.711.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ZohocorpManageEngine OpManager | Affected
| Fixed in
|
AI-suggested
A fixed version 12.8.711 or later should be applied to remediate this vulnerability. Since the affected versions are explicitly stated as prior to 12.8.711, upgrading to 12.8.711 or newer is the recommended remediation. No vendor advisory content was provided to indicate alternative mitigations or temporary fixes. Patch status is confirmed by the affectedVersions field indicating the fix in 12.8.711.
Description
ManageEngine OpManager MSP versions 12.8.709 and below contain a critical remote code execution vulnerability in the Notification Profile module. This vulnerability is due to improper neutralization of special elements used in OS commands (CWE-78), allowing an attacker with limited privileges to execute arbitrary commands remotely. The flaw affects versions prior to 12.8.711 and has a very high CVSS score of 9.9, indicating severe impact on confidentiality, integrity, and availability.