CVE-2026-19929: OpenBoxes · Template Injection
Affects OpenBoxesSource CVE Database V5
Public exploit available · CVSS 5.3 Medium.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- Proof of concept is public or traded
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-08-19.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 16 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by VulDB
, 21 hours before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 3 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenBoxes | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:openboxes:openboxes:*:*:*:*:*:*:*:*
Description
A vulnerability was identified in OpenBoxes up to 0.9.6. This impacts the function buildZebraTemplate of the file grails-app/controllers/org/pih/warehouse/core/DocumentController.groovy of the component Template Processing. The manipulation leads to improper neutralization of special elements used in a template engine. It is possible to initiate the attack remotely. The exploit is publicly available and might be used. Upgrading to version 0.9.8-hotfix1 and 0.9.8 will fix this issue. The identifier of the patch is deeac6a4a7aba86ce99c4bda37142e41d209293e. It is recommended to upgrade the affected component.
References
- vuldb.com/vuln/390180 (opens in a new tab)
- vuldb.com/vuln/390180/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-19929 (opens in a new tab)
- vuldb.com/submit/872054 (opens in a new tab)
- github.com/OpenBoxes/OpenBoxes/security/advisories/GHSA-8wxj-vghp-jpcq (opens in a new tab)
- github.com/OpenBoxes/OpenBoxes/pull/5943 (opens in a new tab)
- gist.github.com/nedlir/220a30213b5a5c6bc26d1000012c6a4d (opens in a new tab)
- github.com/openboxes/openboxes/commit/deeac6a4a7aba86ce99c4bda37142e41d209293e (opens in a new tab)
- github.com/openboxes/openboxes/releases/tag/v0.9.8 (opens in a new tab)
- github.com/OpenBoxes/OpenBoxes/ (opens in a new tab)