CVE-2026-20239: Splunk Enterprise · Information written to log files can be of a sensitive nature and give valuable guidance to an attacker or expose sensitive user information.
Affects Splunk EnterpriseSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 10.2.2 or 10.0.5 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2.2, 10.0.5, 10.3.2512.8 +3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Splunk to 10.2.2 or 10.0.5 (Enterprise); 10.3.2512.8, 10.2.2510.11, 10.1.2507.21 or 10.0.2503.13 (Cloud Platform).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the _internal index to only trusted users and roles to minimize exposure.
Description
CVE-2026-20239 is a vulnerability in Splunk Enterprise and certain versions of Splunk Cloud Platform where sensitive information such as session cookies and response bodies containing sensitive data can be accessed by users with roles that have access to the _internal index. This exposure occurs in Splunk Enterprise versions below 10.2.2 and 10.0.5, and in specified older versions of Splunk Cloud Platform. The vulnerability has a high severity with a CVSS score of 7.5. There are no known exploits in the wild at this time.