Skip to main content
VulnerabilityPublished Updated

CVE-2026-20253: Splunk Enterprise · Missing Authentication

Affects Splunk EnterpriseSource CVE Database V5

0
Compare

Exploited in the wild · KEV due 21 Jun 2026 · public detection template (Nuclei) · 96% EPSS : upgrade to 10.2.4 or 10.0.7 now.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
96.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.4, 10.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 10 Jun 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 8 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Cisco Systems, Inc.

    , 245 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 1 hour after disclosure

  4. , 8 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 11 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Splunk Enterprise to 10.2.4 or 10.0.7.

Affected software

ProductAffectedFixed in
SplunkSplunk EnterpriseAffected
  • >=10.2 <10.2.4
Fixed in
  • 10.2.4
SplunkSplunk EnterpriseAffected
  • >=10.0 <10.0.7
Fixed in
  • 10.0.7

Description

Splunk Enterprise versions 10.2 prior to 10.2.4 and 10.0 prior to 10.0.7 contain a critical vulnerability where the PostgreSQL sidecar service endpoint does not require authentication. This allows unauthenticated network users to create or truncate arbitrary files. Versions 9.4 and earlier are not affected. Disabling the PostgreSQL sidecar service can mitigate the issue if immediate upgrading is not possible.

References

Community reviews

Loading reviews…