CVE-2026-20258: Splunk Enterprise · The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.
Affects Splunk EnterpriseSource CVE Database V5
Not known to be exploited · CVSS 7.1 High · fixed in 10.2.4 : patch Splunk Enterprise soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2.4, 10.0.7, 9.4.12 +5
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Splunk to 10.2.4, 10.0.7, 9.4.12 or 9.3.13 (Enterprise); 10.3.2512.11, 10.2.2510.15, 10.1.2507.23 or 9.3.2411.132 (Cloud Platform).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict dashboard editing permissions to trusted users and educate users to be cautious of phishing attempts that could trigger exploitation.
Description
In Splunk Enterprise versions below 10.2.4, 10.0.7, 9.4.12, and 9.3.13, and Splunk Cloud Platform versions below 10.3.2512.11, 10.2.2510.15, 10.1.2507.23, and 9.3.2411.132, a low-privileged user that does not hold the "admin" or "power" Splunk roles could store a malicious script in a classic dashboard HTML panel, causing unauthorized JavaScript code to execute in the browser of another user. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The low-privileged user should not be able to exploit the vulnerability at will.