CVE-2026-2052: Widget Options (WordPress plugin) · Code Injection
Affects Widget Options (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 4.2.0 : patch Widget Options (WordPress plugin) soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| marketingfireWidget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets | Affected
| Fixed in– |
| Marketing Fire, LLCWidget Options - Extended | Affected
| Fixed in– |
AI-suggested
A partial patch was introduced in version 4.2.0, but versions up to 4.2.2 remain vulnerable. Until an official fix is confirmed, restrict Contributor-level access and above to trusted users only.
Description
The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.
References
- wordfence.com/threat-intel/vulnerabilities/id/68023557-fc92-4cf6-96b4-405ff5a5fd5a?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/widget-options/trunk/includes/widgets/gutenberg/gutenberg-toolbar.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/widget-options/trunk/includes/extras.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3481338/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3514411/ (opens in a new tab)