Skip to main content
VulnerabilityPublished

CVE-2026-2102: Wren Security wrensec-commons · Cross-site Scripting

Affects Wren Security wrensec-commonsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 23.0.0 or 22.6.2 when convenient.

Data as of 2 Nov 2026, 16:43 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WrenSecurity)CVSS 3.16.1
Patch
Available – fixed in 23.0.0, 22.6.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade wrensec-commons and org.wrensecurity.commons/json-resource-http to 23.0.0 or 22.6.2.

Affected software

ProductAffectedFixed in
wrensec-commonsorg.wrensecurity.commons:json-resource-httpAffected
  • >=23.0.0-M1 <23.0.0
Fixed in
  • 23.0.0
wrensec-commonsorg.wrensecurity.commons:json-resource-httpAffected
  • <22.6.2
Fixed in
  • 22.6.2
Mavenorg.wrensecurity.commons/json-resource-httppkg:maven/org.wrensecurity.commons/json-resource-httpOther threatsAffected
  • <22.6.2
  • >=23.0.0-M1 <23.0.0
Fixed in
  • 22.6.2
  • 23.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in wrensec-commons versions 22.6.2 and 23.0.0. Users should upgrade to one of these versions to remediate the issue. No additional mitigations are indicated by the vendor advisory.

Description

wrensec-commons contains a reflected cross-site scripting (XSS) vulnerability in the CREST framework's HTTP binding. The HttpUtils.prepareResponse() method used the _mimeType request parameter to set the Content-Type response header without proper sanitization. By sending a GET request with _mimeType=text/html, an attacker could cause the browser to interpret a CREST JSON response as HTML, enabling execution of arbitrary JavaScript in the victim's browser. The vulnerability is exploitable by tricking a user into visiting a crafted URL targeting any deployed CREST endpoint. The issue is fixed in versions 22.6.2 and 23.0.0.

References

Community reviews

Loading reviews…