CVE-2026-21915: Juniper Networks JSI LWC · Permissive List of Allowed Input
Affects Juniper Networks JSI LWCSource CVE Database V5
Not known to be exploited · CVSS 6.7 Medium : upgrade to 3.0.94 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.94
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Juniper Networks JSI LWC to 3.0.94.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Juniper NetworksJSI LWC | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict local access to trusted users only and monitor for suspicious activity related to the CLI. Avoid running vulnerable versions in untrusted environments.
Description
A Permissive List of Allowed Input vulnerability in the CLI of Juniper Networks Support Insights (JSI) Virtual Lightweight Collector (vLWC) allows a local, high privileged attacker to escalate their privileges to root. The CLI menu accepts input without carefully validating it, which allows for shell command injection. These shell commands are executed with root permissions and can be used to gain complete control of the system. This issue affects all JSI vLWC versions before 3.0.94.