Skip to main content
VulnerabilityPublished

CVE-2026-22105: Delta UFC500 · Use of Default Credentials

Affects Delta UFC500Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.4.18 soon.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (DIVD)CVSS 4.08.7
Patch
Available – fixed in 2.4.18, 4.4.1
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Delta to 2.4.18 (UFC500) or 4.4.1 (UFC500).

Affected software

ProductAffectedFixed in
Delta UFC500msi-imageAffected
  • <2.4.18
Fixed in
  • 2.4.18
Delta UFC500ECPAffected
  • <4.4.1
Fixed in
  • 4.4.1

AI-suggested

Upgrade affected Delta UFC500 devices to version 2.4.18 or later, or 4.4.1 or later, where the vulnerability has been fixed. No other mitigation steps are indicated or required as the issue is resolved in these versions.

Description

Delta Electronics Delta UFC500 charging stations use default credentials for the Service account that are derived from specific character positions of the device serial number. An unauthenticated attacker with adjacent network access can reconstruct or exhaust the password keyspace, allowing unauthorized login to read and modify sensitive settings such as the OCPP backend configuration. This vulnerability affects versions prior to 2.4.18 and 4.4.1, where fixes have been applied.

References

Community reviews

Loading reviews…