Skip to main content
VulnerabilityPublished

CVE-2026-2254: Hitachi Vantara Pentaho Data Integration and Analytics · Incorrect Permissions

Affects Hitachi Vantara Pentaho Data Integration and AnalyticsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 11.0.0.0 or 10.2.0.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.0.0, 10.2.0.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Hitachi Vantara Pentaho Data Integration and Analytics to 11.0.0.0 or 10.2.0.6.

Affected software

ProductAffectedFixed in
Hitachi VantaraPentaho Data Integration and AnalyticsAffected
  • >=10.0 <11.0.0.0
Fixed in
  • 11.0.0.0
Hitachi VantaraPentaho Data Integration and AnalyticsAffected
  • >=1.0 <10.2.0.6
Fixed in
  • 10.2.0.6

AI-suggested

If you cannot patch yet, organizations should review and restrict access to the affected API endpoints where possible, and monitor for unusual activity related to platform mail notifications. No vendor-provided official fix or temporary workaround is currently documented.

Description

Hitachi Vantara Pentaho Data Integration & Analytics versions before 10.2.0.6 and 11.0.0.0, including 9.3.x and 8.3.x, does not apply ACLs on certain API endpoints related to platform mail notfications.

References

Community reviews

Loading reviews…