CVE-2026-22750: VMware Spring Cloud Gateway · CWE-15
Affects VMware Spring Cloud GatewaySource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 4.2.1 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade VMware Spring Cloud Gateway to 4.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| VMwareSpring Cloud Gateway | Affected
| Fixed in
|
Mavenorg.springframework.cloud/spring-cloud-gatewaypkg:maven/org.springframework.cloud/spring-cloud-gatewayOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vendor advisory notes that the 4.2.x branch is no longer under open source support. Users of Spring Cloud Gateway 4.2.0 who are not enterprise customers should upgrade to any 4.2.x release newer than 4.2.0 available on Maven Central or, preferably, to the supported open source releases 5.0.2 or 5.1.1.
Description
CVE-2026-22750 is a high-severity vulnerability in VMware Spring Cloud Gateway version 4.2.0 where the configuration property spring.ssl.bundle is silently ignored, causing the default SSL configuration to be used instead. This misconfiguration can lead to a loss of intended security controls related to SSL, potentially allowing an attacker to interfere with the integrity of the system. The 4.2.x branch is no longer supported in open source, and users are advised to upgrade to newer supported versions such as 5.0.