CVE-2026-23052: Linux kernel · ftrace: Do not over-allocate ftrace memory
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.17.0-1031.31 or 6.17.0-1030.30 when convenient.
Data as of 26 Oct 2026, 13:47 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.17.0-1031.31, 6.17.0-1030.30
Exploitation evidence
Disclosed: evidence found.
CVE published 4 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to 6.17.0-1031.31 or 6.17.0-1030.30.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linux-hwe-edge | Affected
| Fixed in
|
AI-suggested
Official patches are available and have been released by Ubuntu for affected Linux kernel versions. Users should apply the updates promptly and reboot their systems to ensure the fixes take effect. Due to an ABI change in the kernel updates, recompilation and reinstallation of all third-party kernel modules are required. Follow the vendor's update instructions carefully to fully remediate the vulnerability.
Description
A vulnerability in the Linux kernel's ftrace subsystem involving incorrect memory allocation calculations has been resolved. The issue arises because the calculation of remaining pages underestimates available capacity when PAGE_SIZE is not a multiple of ENTRY_SIZE, leading to over-allocation of ftrace memory and triggering kernel warnings. This flaw could potentially be exploited to compromise the system. The vulnerability affects multiple Linux kernel versions prior to 6.17.0-1021.21~24.04.1 and related builds. Official patches are available from Ubuntu, and users are advised to update and reboot to apply fixes. Due to an ABI change, recompilation of third-party kernel modules may be necessary after updating. The severity is assessed as medium based on the impact described.
References
- nvd.nist.gov/vuln/detail/CVE-2026-23052 (opens in a new tab)
- git.kernel.org/stable/c/23936d19e4383c8dfb03931f032473d4baf92533 (opens in a new tab)
- git.kernel.org/stable/c/9aef476717994e96dadfb359641c4b82b521aa36 (opens in a new tab)
- git.kernel.org/stable/c/be55257fab181b93af38f8c4b1b3cb453a78d742 (opens in a new tab)
- git.kernel.org/stable/c/bf802b936a7b269917e4dc233e49f6a928db8286 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23052 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-23052 (opens in a new tab)
- git.kernel.org/linus/be55257fab181b93af38f8c4b1b3cb453a78d742 (opens in a new tab)
- ubuntu.com/security/notices/USN-8570-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8594-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8604-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8605-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8570-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8669-1 (opens in a new tab)