Skip to main content
VulnerabilityPublished Updated

CVE-2026-23060: Linux kernel · crypto: authencesn – reject too-short AAD (assoclen<8) to match ESP/ESN spec

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-23060· High

Not known to be exploited · CVSS 5.5 High · fixed in 4.4.0-1153.159 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.0-1153.159, 4.15.0-1199.214~14.04.1, 4.4.0-279.313~14.04.1 +117
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-20.20
Fixed in
  • 6.17.0-20.20
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in updated linux-aws kernel packages distributed by Ubuntu Pro. Users should apply the relevant kernel updates and reboot their systems to activate the patches. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation is required beyond applying the official updates.

Description

A vulnerability in the Linux kernel's crypto_authenc_esn module allows a NULL pointer dereference leading to a kernel panic (DoS) when processing too-short Additional Authenticated Data (AAD) inputs. This occurs because the module assumes a minimum AAD length that is not enforced, causing out-of-bounds memory access. The issue affects multiple linux-aws kernel versions and has been fixed by adding a minimum AAD length check. The vulnerability has a medium severity with a CVSS score of 5.5 and requires system updates and reboots to apply the fix.

References

Community reviews

Loading reviews…