Skip to main content
VulnerabilityPublished Updated

CVE-2026-23073: Linux kernel · wifi: rsi: Fix memory corruption due to not set vif driver data size

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-23073· High

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1105.112~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1105.112~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1106.115~20.04.1 +70
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • 6.14.0-15.15 – 6.17.0-40.40
20 affected builds
Fixed in–
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1019.19
17 affected builds
Fixed in–
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1006.6 – 6.17.0-1020.22
17 affected builds
Fixed in–
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1005.5 – 6.17.0-1018.18
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vendor advisory from Ubuntu confirms fixes in linux-aws kernel versions 5.15.0-1105.112~20.04.1 and later. After applying the update, a system reboot is required. Note that due to ABI changes, third-party kernel modules may need recompilation and reinstallation. Follow the vendor's update instructions carefully to ensure full remediation.

Description

A memory corruption vulnerability in the Linux kernel's RSI911x WiFi driver was fixed. The issue arises because the driver does not set the vif driver data size, leading to out-of-bounds memory access and corruption when the driver uses this data. This flaw could allow an attacker with local privileges to cause memory corruption, potentially leading to system compromise. The vulnerability affects specific linux-aws kernel versions prior to 5.15.0-1105.112~20.04.1 and related versions. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…